Vous êtes sur le site public du Cert-IST
Vulnérabilité dans les lecteurs de fichiers PDF

Date :22 Juin 2005

Publication: Article

Ce mois-ci, une vulnérabilité (CERT-IST/AV-2003.195) a été découverte dans les lecteurs de fichiers PDF sous les environnements Unix et Linux. Les versions Microsoft et Apple des lecteurs PDF ne sont pas affectées par ce problème. Cette vulnérabilité permet à un fichier PDF malicieux d'exécuter des actions nuisibles sur le système, lorsque ce dernier est ouvert avec un lecteur vulnérable et que la victime clique sur un lien (URI) malicieux contenu dans ce fichier.

Il est intéressant de voir que la vulnérabilité exploite les possibilités du langage de commandes Unix (le shell). Elle n'est donc pas spécifique à une architecture particulière.

Cet évènement tend à prouver que les fichiers PDF peuvent être dans certaines circonstances porteurs de code malicieux

L'utilisation de cette vulnérabilité a permis de démontrer au travers de tests que la conception de vers Unix à travers les documents PDF était envisageable. Cependant, la propagation de ces derniers est subordonnée à l'utilisation de lecteurs PDF vulnérables.

De plus, une analyse des spécifications du format PDF (versions 1.1, 1.2 et 1.3) a permis de remarquer que les liens (URI) dans les fichiers PDF pouvaient contenir, pour plus d'interactivité avec les utilisateurs, des actions pouvant amener à des comportements plus ou moins malicieux :

  • Launch : lance une application (format PDF version 1.1)
  • SubmitForm : envoie des données vers une URL (format PDF version 1.2)
  • JavaScript : exécute un script JavaScript (format PDF version 1.31)

Il est donc essentiel de rester vigilant vis-à-vis des liens contenus dans les documents PDF.

Le Cert-IST remercie le CERT-A pour les informations fournies lors de l'élaboration de cet article.

Pour plus d'information :